Is my computer compatible?

Windows

Cube Link is compatible with PCs that are running Windows 7 or later. Cube Link will also require .NET framework 4.0 or later to be installed on the system. 

Mac OSX

Cube Link is compatible with Mac OS X 10.10 or higher as well as Bluetooth 4.0 (BLE) hardware to be installed on the system.

Cube Link for PC and Mac can be downloaded from our website here.

If you wish to use Cube Link in conjunction with Adobe Photoshop, we recommend using the latest version of Adobe Photoshop.

 

Have more questions? Submit a request

Comments